For the complete documentation index, see llms.txt. This page is also available as Markdown.

Руководство по настройке Obsidian

Настройки данных → настройка Obsidian

Cherry Studio поддерживает интеграцию с Obsidian, позволяя экспортировать весь диалог или отдельное сообщение в хранилище Obsidian.

Последнее руководство

По сравнению со старым экспортом в Obsidian, новая функция экспорта в Obsidian может автоматически выбирать путь к хранилищу, больше не нужно вручную вводить имя хранилища и имя папки.

Шаг 1: Настройка Cherry Studio

Откройте в Cherry StudioНастройки → Настройки данных → Конфигурация Obsidianв меню, в выпадающем списке автоматически появятся имена хранилищ Obsidian, уже открытых на этом компьютере; выберите целевое хранилище Obsidian:

Шаг 2: Экспорт диалога

Экспорт полного диалога

Вернитесь к окну диалога в Cherry Studio, щёлкните правой кнопкой по диалогу и выберитеЭкспорти нажмитеЭкспорт в Obsidian:

После этого появится окно, в котором можно настроить для этой заметки диалога, экспортируемой в Obsidian, Properties (свойства),размещаемую в Obsidian папку а также способ обработки при экспорте в Obsidian:

  • Хранилище: нажмите на выпадающее меню, чтобы выбрать другое хранилище Obsidian

  • Путь: нажмите на выпадающее меню, чтобы выбрать папку для сохранения экспортированной заметки диалога

  • Как свойства заметки Obsidian (Properties):

    • теги (tags)

    • время создания (created)

    • источник (source)

  • способ обработки при экспорте в Obsidian доступны три варианта:

  • способ обработки при экспорте в Obsidian доступны три варианта:

    • Создать новую (если существует, перезаписать): между Путь в указанной папке создаст новую заметку диалога; если заметка с таким именем уже существует, старая заметка будет перезаписана

    • В начало: если заметка с таким именем уже существует, экспортируемое содержимое выбранного диалога будет добавлено в начало этой заметки

    • Добавить в конец: если заметка с таким именем уже существует, экспортируемое содержимое выбранного диалога будет добавлено в конец этой заметки

Только первый способ включает Properties (свойства), два других способа Properties (свойства) не включают.

Настройка свойств заметки
Выбор пути
Выбор способа обработки

После выбора всех параметров нажмите «ОК», чтобы экспортировать полный диалог в соответствующую папку соответствующего хранилища Obsidian.

Экспорт одного сообщения

Для экспорта отдельного сообщения нажмите наменю из трёх полосоки выберитеЭкспорти нажмитеЭкспорт в Obsidian:

Экспорт одного сообщения

после этого также появится такое же окно, как при экспорте полного диалога, в котором нужно настроить свойства заметки и способ обработки заметкии так же, как в руководстве выше завершите настройку.

Экспорт успешно выполнен

🎉 На этом поздравляем: вы завершили все настройки интеграции Cherry Studio с Obsidian и полностью прошли весь процесс экспорта, enjoy yourselves!

Экспорт в Obsidian
Посмотреть результат экспорта

Старое руководство (для Cherry Studio<v1.1.13)

Шаг 1: Подготовьте Obsidian

Откройте хранилище Obsidian и создайтепапкепапку для сохранения экспортированных диалогов (на изображении в качестве примера используется папка Cherry Studio):

Обратите внимание на текст, выделенный в левом нижнем углу, здесь указано ваше Хранилище имя хранилища

Шаг 2: Настройка Cherry Studio

В Cherry Studio в разделе 【Настройки】→【Данные】→【Конфигурация Obsidian】 нужно лишь выбрать хранилище Obsidian по умолчанию: Cherry Studio автоматически обнаружит уже имеющиеся на этом компьютере хранилища Obsidian; просто выберите нужное в выпадающем списке.

【Настройки】→【Данные】→【Конфигурация Obsidian】: выбрать хранилище Obsidian по умолчанию

Здесь настраивается только хранилище по умолчанию.В какую именно папку сохранять и какие теги добавлять, выбирается в диалоговом окне 【Настройка свойств заметки】, которое появляется при каждом экспорте(см. следующий шаг); заранее в настройках это указывать не нужно. Если в выпадающем списке отображается сообщение «Хранилище Obsidian не найдено», сначала убедитесь, что Obsidian установлен на этом компьютере и как минимум одно хранилище уже создано.

Шаг 3: Экспорт диалога

Экспорт полного диалога

Вернитесь к окну диалога в Cherry Studio, щёлкните правой кнопкой по диалогу и выберитеЭкспорти нажмитеЭкспорт в Obsidian.

После этого появится окно, в котором можно настроить для этой заметки диалога, экспортируемой в Obsidian, Properties (свойства)а также обработки при экспорте в Obsidianпри экспорте в Obsidian. При экспорте в Obsidian обработки при экспорте в Obsidian доступны три варианта:

  • Создать новую (если существует, перезаписать): между в шаге 2 указанное папке создаст новую заметку диалога; если заметка с таким именем уже существует, старая заметка будет перезаписана

  • В начало: если заметка с таким именем уже существует, экспортируемое содержимое выбранного диалога будет добавлено в начало этой заметки

  • Добавить в конец: если заметка с таким именем уже существует, экспортируемое содержимое выбранного диалога будет добавлено в конец этой заметки

Настройка свойств заметки

Только первый способ включает Properties (свойства), два других способа Properties (свойства) не включают.

Экспорт одного сообщения

Для экспорта отдельного сообщения нажмите наменю из трёх полосоки выберитеЭкспорти нажмитеЭкспорт в Obsidian.

Экспорт одного сообщения

после этого также появится такое же окно, как при экспорте полного диалога, в котором нужно настроить свойства заметки и способ обработки заметкии так же, как в руководстве выше завершите настройку.

Экспорт успешно выполнен

🎉 На этом поздравляем: вы завершили все настройки интеграции Cherry Studio с Obsidian и полностью прошли весь процесс экспорта, enjoy yourselves!

Экспорт в Obsidian
Посмотреть результат экспорта

Получить помощь и отправить отзыв

Если у вас в процессе настройки или использования возникнут какие-либо вопросы, баги или предложения по улучшению функций, пожалуйста, обратитесь к Отзывы и предложения официальным каналам, указанным там.

Последнее обновление

Это было полезно?